Close

WordPressのPlugin(syntaxhighlighter)をアップデートしようと思ったら「This is usually due to inconsistent file permissions」のエラー

ある日、WordpressのPlugin(syntaxhighlighter)をアップデートしようと思ったら、以下のようなエラーが発生した。 ※Wordpress環境:AWSの「WordPress powered by Bitnami」を利用 アップデートの際に一時的にできるファイルはこれっぽいが、 特におかしなところはない。 一度消してから、アップデートもしてみたけど変わらず、、 プラグインのありかはこちら あー、、fileのpermissionは大丈夫そうだけど、 ごみ(「syntaxhighlighter.php.20190211」「syntaxhighlighter.php.20190212」)が残っている、、、 消してみる これでうまくいった

Nginxコンテナに、Let’s Encryptで証明書を自動更新で当てたい場合

サクッとDocker始める docker事始め で作成したnginxコンテナに、Let’s Encryptで証明書を当てたい場合 Let’s Encryptの証明書を更新する(Bitnami on AWS) Let’s Encryptの証明書を更新する(EC2) AmazonLinuxのSSL化対応 この辺りで言及している通り、一度Apache/Nginxを停止してから更新する必要があある 止めていないと以下のようなエラーが出る 通信ルールで遮断している場合も同じエラーがでる模様 参考: Let’s Encryptの証明書を更新する(Bitnami on AWS) 当たり前だけど、DockerでNginxを動かしている場合は、コンテナを止めなければいけない 自動で更新されるように、crontabに入れるなkらこんな感じ